Close

Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    Jan 2022
    Posts
    10
    Tournaments Joined
    0
    Tournaments Won
    0

    Is Replicate bugged?

    It seems Replicate only works on allyís that cost 3 resources to summon, but it doesnít specify that on the card. If itís not bugged I feel like the description should be more specific and say the ally must cost 3 resources.

  2. #2
    DP Visionary tman507's Avatar
    Join Date
    Jul 2012
    Location
    U.S.A, GMT -7
    Posts
    4,625
    Tournaments Joined
    6
    Tournaments Won
    0
    Worked fine for me with 6cc Forgotten Horror. Did you for sure have an ally on your board with the same name as the one you were trying to seek? Other possibility is that maybe you had no more copies of the card you wanted to seek left in your deck.
    "IT'S TIME TO DUEL!!!"
    "The Magnificent."
    Account for any future SC transfers by Gondorian: BP tman507

    Member of PFG3
    Master of Hand-to-hand Combat
    Warrior of the Blue Phoenix
    Greatness, Reborn

    Official Shadow Era Wiki Moderator

  3. #3
    Junior Member
    Join Date
    Jan 2022
    Posts
    10
    Tournaments Joined
    0
    Tournaments Won
    0
    Quote Originally Posted by tman507 View Post
    Worked fine for me with 6cc Forgotten Horror. Did you for sure have an ally on your board with the same name as the one you were trying to seek? Other possibility is that maybe you had no more copies of the card you wanted to seek left in your deck.
    Yeh I had on the board a Crystal Titan, a Brutalis, and a Infernal Gargoyle. I used replicate and let me search my deck, i could scroll through my cards and see the cards I wanted to summon, but only the Infernal Gargoyle was highlighted green, the others werenít clickable. Iíll do some more experimenting but it seems like it was bugged for me.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •