Close

Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    Jan 2016
    Posts
    25
    Tournaments Joined
    0
    Tournaments Won
    0

    Card never loads in PC

    I installed the PC version of shadow era with the new release of Lost Lands. But when I started it the card image never loaded. I read some post about this and thought that it would just take some time before it would load but I waited for more than 30 min and nothing happened. I already tried reinstalling, re-downloading but still the same problem. Please look into this Shadow Era.

  2. #2
    Senior Member Drevo Triska's Avatar
    Join Date
    Nov 2011
    Location
    Prague,CZE GMT+2
    Posts
    190
    Tournaments Joined
    3
    Tournaments Won
    0
    Blog Entries
    1
    me too

  3. #3
    DP Visionary Index's Avatar
    Join Date
    Nov 2012
    Location
    Shanghai(GMT+8)
    Posts
    5,900
    Tournaments Joined
    9
    Tournaments Won
    0
    It crashes a lot when loading:/
    Buried Treasure of Nanana
    Warrior of the Blue Phoenix/ Greatness, Reborn
    My tournament achievements

  4. #4
    Senior Member Saf's Avatar
    Join Date
    May 2013
    Location
    MK, England
    Posts
    333
    Tournaments Joined
    1
    Tournaments Won
    0
    Are you guys seeing the attack and health of the cards? I see just those 2 numbers otherwise the card itself is blank and transparent
    BP Inactive member | IGN: SafOne

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •