Close

Results 1 to 10 of 10
  1. #1
    Junior Member
    Join Date
    Nov 2013
    Posts
    7
    Tournaments Joined
    0
    Tournaments Won
    0

    Error after 2.30 download

    hello

    i downloaded the latest update of the game to my netbook, an eee pc 1005HA

    i never had problems with the games update from 2.012 to 2.024
    after downloading the screen shows error which said failed to initialize player
    that Directx9 gpu model shader 2.0 is needed, and that my chipset only supports shader model 2.0.

    details in the error screen:

    failed to initialize player

    DirectX9 GPU (Shader Model 2.0) is required.
    Your GPU (Mobile Intel(R) 945 Express Chipset Family)
    only supports Shader Model 2.0

    i like the game i even supported it on KS but if i cant resolve this i may have to stop playing it alltogether.

    i hope someone can help
    Last edited by RaguelSpectre; 11-16-2013 at 08:13 AM.

  2. #2
    Junior Member
    Join Date
    Nov 2013
    Posts
    2
    Tournaments Joined
    0
    Tournaments Won
    0
    Hi

    I have the same problem on my Samsung Netbook.
    The error message is exactly the same as above:

    DirectX9 GPU (Shader Model 2.0) is required.
    Your GPU (Mobile Intel(R) 945 Express Chipset Family)
    only supports Shader Model 2.0

    The browser version reads:
    Unity Web Player requires DX9 level graphics card.
    Make sure you have graphics card drivers installed.

    My drivers are all up to date (since 2010, gotta love xp) and I never had any problems before 2.03
    I hope someone has an idea what causes this, since I am limited to this netbook atm and I REALLY want to play.

    Edit: Seems to be a problem with the latest Unity Player update.
    I don't know how this affects the pc client but the only solution semmst to be to wait for the Unity Player to be fixed and hope they don't abandon the older GPUs.
    Im still open for other ideas
    Last edited by TheNewRiddler; 11-16-2013 at 03:40 PM.

  3. #3
    Junior Member
    Join Date
    Nov 2013
    Posts
    7
    Tournaments Joined
    0
    Tournaments Won
    0
    hey new riddler,

    Unity 4.2.2 seems to be working. Idk if the upgrade to 4.3 supports older models.

    As for the pc client i hope somebody in support helps us.

  4. #4
    Devoted Fan Gondorian's Avatar
    Join Date
    Apr 2011
    Location
    England (GMT+0)
    Posts
    24,077
    Tournaments Joined
    1000
    Tournaments Won
    999
    Blog Entries
    1
    Quote Originally Posted by JUSTICAR View Post
    If your graphics card cannot play it you can try downloading "Swift Shader 3.0"... place the "d3d9.dll" file in the shadowera installation folder then you can play shadowera even without upgrading your graphics card. (only draw back would be that you'll have the swiftshader logo in the game)

    I think its an issue with the new Unity Player... prolly Kyle has a solution to it just like what swiftshader does, but without the watermark logo.
    Try this.

  5. #5
    Senior Member maskee's Avatar
    Join Date
    Jan 2013
    Location
    Czech Republic
    Posts
    527
    Tournaments Joined
    0
    Tournaments Won
    0
    So it is problem of Unity Web player. But looks like it is a bug, bcs it happends also on GPU which support DX9c like mine (Intel Graphic Media Accelerator 3150).
    Here you can see it : http://answers.unity3d.com/questions...r-working.html
    So there is a chance they will fix it.
    Last edited by maskee; 11-29-2013 at 06:12 AM.
    IGN: TJ Maskee - Proud member of Team Juggernauts !

  6. #6
    Devoted Fan Gondorian's Avatar
    Join Date
    Apr 2011
    Location
    England (GMT+0)
    Posts
    24,077
    Tournaments Joined
    1000
    Tournaments Won
    999
    Blog Entries
    1
    Quote Originally Posted by maskee View Post
    So it is problem of Unity Web player. But looks like it is a bug, bcs it happends also on GPU which support DX9c like mine (Intel Graphic Media Accelerator 3015).
    Here you can see it : http://answers.unity3d.com/questions...r-working.html
    So there is a chance they will fix it.
    Thanks for posting that. It's great they are working on it because we have no choice but to move up to the latest Unity Player.

  7. #7
    Junior Member
    Join Date
    Nov 2013
    Posts
    7
    Tournaments Joined
    0
    Tournaments Won
    0
    Quote Originally Posted by Gondorian View Post
    Try this.
    I tried as what was suggested, still does not function. It reads like this:

    SE.exe-Application error:

    The instruction at 0x0ded56ab referenced memory at 0x0dafe030. The memory coul not be read.

    No problems with the pc client before why is the update not working?

  8. #8
    Senior Member maskee's Avatar
    Join Date
    Jan 2013
    Location
    Czech Republic
    Posts
    527
    Tournaments Joined
    0
    Tournaments Won
    0
    Quote Originally Posted by Gondorian View Post
    Thanks for posting that. It's great they are working on it because we have no choice but to move up to the latest Unity Player.
    I am not sure if they will fix it or just say, ok those graphic cards are no longer supported (bcs its easier than making fix for few customers). I had question you mentioned, is here any choice to run se on previous version of Unity Player or you have to use the latest one? Bcs nobody had problems on previous one.
    IGN: TJ Maskee - Proud member of Team Juggernauts !

  9. #9
    Member
    Join Date
    Jan 2012
    Posts
    32
    Tournaments Joined
    0
    Tournaments Won
    0
    So! I resolved this problem with a shader emulator, do the download of this link and paste this three archives in shadowera_data past.

    http://www.4shared.com/get/Z36T7IbS/...ded_by_su.html

    Sorry about my english, I'm brazillian and english isn't my native language

  10. #10
    Junior Member
    Join Date
    Nov 2013
    Posts
    2
    Tournaments Joined
    0
    Tournaments Won
    0
    Good news

    Unity Player has released 4.3.1 and now the web player does work for me again.
    Would be nice if the fixes could be implemented in the PC client soon because the performance of the browser version is a bit suboptimal.
    Still I#m really happy to be able to play again. Kickstarter here I come!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •