Close

Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20
  1. #11
    Member
    Join Date
    Dec 2011
    Posts
    61
    Tournaments Joined
    0
    Tournaments Won
    0
    Quote Originally Posted by AnAdolt View Post
    Does it crash with the Mac client from our download page?
    Yes. The problem started with the SE client. I thought possibly moving to the Unity download I may see a difference. It turns out that they have the exact same build as SE.

  2. #12
    Member
    Join Date
    Dec 2011
    Posts
    61
    Tournaments Joined
    0
    Tournaments Won
    0
    Quote Originally Posted by AnAdolt View Post
    Does it crash with the Mac client from our download page?
    I'm trying to see if there is a compatibility issue with my machine. I used the Object Tool to see which libraries your Unity player needs and the report is posted below. Does anything seem out-of-place here?

    Code:
    /Library/Internet Plug-Ins/Unity Web Player.plugin/Contents/MacOS/Unity Web Player:
            /System/Library/Frameworks/Quartz.framework/Versions/A/Quartz (compatibility version 1.0.0, current version 1.0.0)
            /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation (compatibility version 150.0.0, current version 476.19.0)
            /System/Library/Frameworks/QuickTime.framework/Versions/A/QuickTime (compatibility version 1.0.0, current version 1327.73.0)
            /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon (compatibility version 2.0.0, current version 136.0.0)
            /usr/lib/libcrypto.0.9.7.dylib (compatibility version 0.9.7, current version 0.9.7)
            /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa (compatibility version 1.0.0, current version 12.0.0)
            /System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL (compatibility version 1.0.0, current version 1.0.0)
            /usr/lib/libstdc++.6.dylib (compatibility version 7.0.0, current version 7.4.0)
            /usr/lib/libgcc_s.1.dylib (compatibility version 1.0.0, current version 1.0.0)
            /usr/lib/libmx.A.dylib (compatibility version 1.0.0, current version 47.1.0)
            /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 111.1.4)
    The Unity plugin seems to be reporting generic compatibility versions. Hopefully your team can see which versions I have that may be incompatible.

  3. #13
    Member
    Join Date
    Dec 2011
    Posts
    61
    Tournaments Joined
    0
    Tournaments Won
    0
    Update:
    I deleted all Unity players and ShadowEra caches, and the Unity configuration folder. I restarted my machine in OSX Tiger 10.4.11, the exact same error occurs as when I run it on Leopard 10.5.8. Tiger uses a different version of LibSystem.B.dylib. Moonstalker's native ability and Speedstrike crash every browser every time.

    Both abilities are causing LibSystem.B.dylib to call unmapped memory, and it's always in the same location (0x96ef02ac, or about 2.388 GB). My machine has 1.75 GB physical RAM now so that call is in VM - I think.

    Then I removed a half-stick or RAM from 1 slot in my machine because I thought it may be a problem with the mismatched RAM. I reseated three 512-Mb DIMMs into different slots and rebooted. Now running with 1.5GB, exact same problem.

    I don't think anything is wrong with my machine. Completely changing the OS and memory have no effect. I don't think this build works completely on the PowerPC platform. I have dual processors, and I don't know if that could be the problem. They are original Apple CPUs, not aftermarket.

    Does anyone have an idea what is happening to make these bad memory calls with Speedstrike and Moonstalker?
    Last edited by Vogon Poet; 12-30-2011 at 07:41 PM.

  4. #14
    Member
    Join Date
    Dec 2011
    Posts
    61
    Tournaments Joined
    0
    Tournaments Won
    0
    Blood Frenzy causes the same freeze in the exact same memory location.

    The freeze happens as soon as Blood Frenzy attached to my opponent.

    It looks like the problem starts with Moonbundle. This trace shows Moonbundle calling LibSystem.B.dylib which eventually leads to the crash.

    Game: SERGIO526 vs. Primordial Ooz
    Code:
    Date/Time:       2011-12-30 17:33:19.972 -0500
    OS Version:      Mac OS X 10.5.8 (9L31a)
    Report Version:  6
    Anonymous UUID:  D74C4CD4-D043-4AEF-B872-ED819C9DB3D4
    
    Exception Type:  EXC_CRASH (SIGABRT)
    Exception Codes: 0x0000000000000000, 0x0000000000000000
    Crashed Thread:  16
    ...
    
    Thread 16 Crashed:
    0   libSystem.B.dylib             	0x96ef02ac __semwait_signal_nocancel + 8
    1   libSystem.B.dylib             	0x96eefd78 nanosleep$NOCANCEL$UNIX2003 + 176
    2   libSystem.B.dylib             	0x96ee8fdc usleep$NOCANCEL$UNIX2003 + 68
    3   libSystem.B.dylib             	0x96f02b9c __abort + 88
    4   libSystem.B.dylib             	0x96f02c04 abort + 96
    5   libSystem.B.dylib             	0x96ed1fe8 internal_catch_exception_raise + 116
    6   libSystem.B.dylib             	0x96ebe400 _Xexception_raise + 260
    7   libSystem.B.dylib             	0x96ebe2a4 exc_server + 164
    8   com.OverTheEdge.MonoBundle    	0x19fb2870 catch_exception_raise + 128

  5. #15
    Junior Member
    Join Date
    Dec 2011
    Posts
    3
    Tournaments Joined
    0
    Tournaments Won
    0
    I think I have the same problem as you on my web browser. The mac client doesn't even work on my computer (OS 10.4.11 and 10.5.8 I think). But my problem is even worse as it also happens with other hero buff cards.
    Last edited by Sir Evermore; 01-04-2012 at 07:23 PM.

  6. #16
    Member
    Join Date
    Dec 2011
    Posts
    61
    Tournaments Joined
    0
    Tournaments Won
    0
    Quote Originally Posted by Sir Evermore View Post
    I think I have the same problem as you on my web browser. The mac client doesn't even work on my computer (OS 10.4.11 and 10.5.8 I think). But my problem is even worse as it also happens with other hero buff cards.
    When Safari crashes, open the Crash Report and copy the crashed thread log into here. It will say something like mine:

    "Thread 16 Crashed:
    0 libSystem.B.dylib 0x96ef02ac __semwait_signal_nocancel + 8
    1 libSystem.B.dylib 0x96eefd78 nanosleep$NOCANCEL$UNIX2003 + 176
    2 libSystem.B.dylib 0x96ee8fdc usleep$NOCANCEL$UNIX2003 + 68
    3 libSystem.B.dylib 0x96f02b9c __abort + 88
    4 libSystem.B.dylib 0x96f02c04 abort + 96
    5 libSystem.B.dylib 0x96ed1fe8 internal_catch_exception_raise + 116
    6 libSystem.B.dylib 0x96ebe400 _Xexception_raise + 260
    7 libSystem.B.dylib 0x96ebe2a4 exc_server + 164
    8 com.OverTheEdge.MonoBundle 0x19fb2870 catch_exception_raise + 128"

    See if it's the same thing I'm getting. I have a hard time believing there is anything wrong with my computer since changing the entire Operating System has no effect on the symptoms.

  7. #17
    Senior Member AnAdolt's Avatar
    Join Date
    Jan 2011
    Location
    BC, Canada
    Posts
    8,428
    Tournaments Joined
    0
    Tournaments Won
    0
    The Mac App Store no longer supports a universal build that is compatible on older Macs with a PowerPC processor and newer Macs with an Intel processor. That's why the current Shadow Era Mac client is an Intel build and has problems on older Macs. We'll try to release a universal build on our download page. I'll have to remember to post here once it's up.

  8. #18
    Member
    Join Date
    Dec 2011
    Posts
    61
    Tournaments Joined
    0
    Tournaments Won
    0
    It may be as simple as letting the Unity3D developers debug it since the Unity player still supports PowerPC architecture. Actually, I'm pretty sure the problem lies in Mono based on all my crash reports.

  9. #19
    Senior Member AnAdolt's Avatar
    Join Date
    Jan 2011
    Location
    BC, Canada
    Posts
    8,428
    Tournaments Joined
    0
    Tournaments Won
    0
    That would be the more eloquent solution but estimate-wise, it's likely the longer of the two in terms of when it'll surface.

  10. #20
    Member
    Join Date
    Dec 2011
    Posts
    61
    Tournaments Joined
    0
    Tournaments Won
    0
    Downloaded the source for the latest PPC Mono. How hard would it be to replace your distribution with my own build? Can I just rename it and place it in the framework Resources folder?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •